Powerjection III EFI System - Page 3 - Texas 4x4 Forum

Go Back   Texas 4x4 Forum > Technical > Tech Writeups

Photo Gallery Places to Wheel Gallery III Home Forum Tech Section IRCChat FlashChat

Texas4x4.org is the premier All All Forum on the internet. Registered Users do not see the above ads.

Tech Writeups:

Powerjection III EFI System



Like Tree6Likes

Reply
 
Share LinkBack Thread Tools Display Modes
Old 07-10-2013, 02:37 PM   #51
Wheels 4 Food
 
Join Date: Nov 2008
Location: Clovis NM
Posts: 3,661
Elcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud of
[QUOTE=painter66;7921]I'll checkit out better I have taken it apart three time blowen it out and applied dilectric to the pins. I disconected the tac in the cab hoping it was somehow the problem but it didn't change anything. This would be the second ECU that has sercome to moisture. the first one the circuit boad was accualy corrioded. Guess I'll have to scrap the injection unit or spend another $400.00. Do you see runnining into any problems if the wires were extended so I could move the ECU? Is the TB used as a heat sink to cool it? What do you think about moving it inside the cab?[/
__________________
Got to get back to work this playing around isn't paying the bills.

http://i975.photobucket.com/albums/a...Picture769.jpg
Elcaminoman is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-10-2013, 02:37 PM   #52
Wheels 4 Food
 
Join Date: Nov 2008
Location: Clovis NM
Posts: 3,661
Elcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud of
..........
Quote:
Originally Posted by schum View Post
I feel your pain. I just spent a month and a half trying to get my brakes to work properly. After putting aftermarket booster, master, calipers, pads and rotors I gave up and removed it all and rebuilt the stock booster and put all the stock parts back on and it works better than the aftermarket stuff. Who would guess.

What are you using for an ignition. Did it get wet.
__________________
Got to get back to work this playing around isn't paying the bills.

http://i975.photobucket.com/albums/a...Picture769.jpg
Elcaminoman is offline   Reply With Quote
Old 07-10-2013, 02:38 PM   #53
Wheels 4 Food
 
Join Date: Nov 2008
Location: Clovis NM
Posts: 3,661
Elcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud of
.........

First thanks for the help!



So what Co. were the brakes from just want t make sure I don't order from them.



I'm running a stock chevy HEI. The engine never sees over 5200 rpm so not to big a deal. most of the time we're under 2500. I installed a new coil rotor cap and modual. nothing helped. Yes it got wet.



As for the Jeep I call PP and talked with Doug. He wanted me to check to make sur the Key light didn't go out when it was cranking. I did and sur eenough it .................................................. ....... Stays on. Anyway if there is a good side to all this, the unit is just under 1 yr old he said to send it back and he would fix or replace it. When I asked how long it would take he said we tell people 1 week so I figure 2 to 3 . I told him to think a couple days about how cheep he would sell a good old boy thats had more than enough problems a spair ECU. If I extend the wiring and move it inside the Jeep it would be easy to change I could even mount it like NASCAR and just switch boxes with a flip aof a couple switches LOL. Could even have different tunes loaded. OK maybe getting a little carried away LOL. Got it running long enough to park it outside where it can sit for a bit. Tomorrow I'll pull the TB and box it up.
__________________
Got to get back to work this playing around isn't paying the bills.

http://i975.photobucket.com/albums/a...Picture769.jpg
Elcaminoman is offline   Reply With Quote
 
Old 07-10-2013, 02:39 PM   #54
Wheels 4 Food
 
Join Date: Nov 2008
Location: Clovis NM
Posts: 3,661
Elcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud of
..............

Quote:
Originally Posted by Steiner View Post
I was talking about once it lit off. If mine started hot with the IAC at 170 it would put it in the woods. You are correct in how to adjust it....get it hot and then adjust your butterflies until your IAC reads 15 or less at your target idle. I set my target idle to somewhere around 800 but adjust the butterflies to 850 RPM. That way the IAC is trying to close all the way. Then you'll have to shut down, turn the key back on, and do a TPS recalibration.

After that is done connect your PC with the key on to make a couple of changes in some areas.
First, go into the IAC menu and change the cranking IAC value to 85 and do a SEND.
Next, go into the cranking screen and change all of your "fuel injector prime" to 50ms in each of the three fields, then do a SEND.

Turn the key off for at least a minute, then turn the key on for a few seconds until you hear the fuel prime shot and then try to crank.

Your timing will also affect startups. I ran both an HEI and a MSD 8360 both at 14 degrees initial. With the HEI, I ran ported vacuum advance. With the 8360 I ran full manifold advance. I think once I went full manifold I was able to lower my cranking fuel by 40% or so. Guess the can pulls in some during cranking.
__________________
Got to get back to work this playing around isn't paying the bills.

http://i975.photobucket.com/albums/a...Picture769.jpg
Elcaminoman is offline   Reply With Quote
Old 07-10-2013, 02:40 PM   #55
Wheels 4 Food
 
Join Date: Nov 2008
Location: Clovis NM
Posts: 3,661
Elcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud of
Well when I get the ECU back from Douge I'll try some of that.



Turns out the ECU was less than a year old and should be under warrinty. Yea Boo. I'll get it fixed or a new on (already cost $48.00) for shipping and insurance. That's the good the bad is it only lasted less than a year. Funny when I asked about insrance at the post office the guy who I knew said did you ever loose anything in the mail I said no. Then asked if it did get lost would he cough ut the $1,700.00 to replace it $18.00 for $1,700.00 of insurance an't bad. So now we wait.
__________________
Got to get back to work this playing around isn't paying the bills.

http://i975.photobucket.com/albums/a...Picture769.jpg
Elcaminoman is offline   Reply With Quote
Old 07-10-2013, 02:40 PM   #56
Wheels 4 Food
 
Join Date: Nov 2008
Location: Clovis NM
Posts: 3,661
Elcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud of
Update: I sent the ECU off on the 11th of June with a return receipt. Got the receipt back on the 18th. I waited till the 21st to call and was told they had just got it. Lie #1. They had it for At least 5-7 days I had proof. So I called again on the 26th and was told they just got it and it would know something Friday or Monday and would let me know. Lie #2. That would of been the 29th of June or the 1st of July that we should of known something. I called yesterday 8 July and was told that it was on the bench but no one has looked at it yet. So it's bee on the bench for 2 week and no one has touched it?



Doug told me when I call about sending it in that this would take a week. WTF is going on over at PP? If I didn't have over $2,000.00 invested in this thing I'd go a different direction. The dam ECU only had 59 hr's on it 4-5 was tring to figure out what the hell was wrong with it, the first one I can't remember but it wasn't very many Hrs.
__________________
Got to get back to work this playing around isn't paying the bills.

http://i975.photobucket.com/albums/a...Picture769.jpg
Elcaminoman is offline   Reply With Quote
Old 07-10-2013, 02:41 PM   #57
Wheels 4 Food
 
Join Date: Nov 2008
Location: Clovis NM
Posts: 3,661
Elcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud of
Well got a call today from PP. The ECU did get water in it. Burnt the tack signal on the circuit board. I was told they thought they had the water intrusion problem fixed but evidently not. There was a void in the sealant on mine. They have added a shaker to help while poring the sealant to help with this problem. So luckily it was less than a year old and should be in the mail today or tomorrow. Also asked about extending the wire so I could move the ECU inside the cab. No resistor wires so no problem moving it. He was a bit concerned about all the splices and water getting in that way. I think solder everything and use the heat shrink with the glue in it should be OK. This is the same thing that happen to the first ECU I had. The board has corrosion on it. I still have it if anyone wants to see it I'll post a picture.
__________________
Got to get back to work this playing around isn't paying the bills.

http://i975.photobucket.com/albums/a...Picture769.jpg
Elcaminoman is offline   Reply With Quote
Old 07-10-2013, 03:16 PM   #58
Flex Master
 
Join Date: May 2007
Location: Schertz
Posts: 1,439
dabshr is a jewel in the roughdabshr is a jewel in the roughdabshr is a jewel in the rough
Quote:
Originally Posted by Elcaminoman View Post
Well got a call today from PP. The ECU did get water in it. Burnt the tack signal on the circuit board. I was told they thought they had the water intrusion problem fixed but evidently not. There was a void in the sealant on mine. They have added a shaker to help while poring the sealant to help with this problem. So luckily it was less than a year old and should be in the mail today or tomorrow. Also asked about extending the wire so I could move the ECU inside the cab. No resistor wires so no problem moving it. He was a bit concerned about all the splices and water getting in that way. I think solder everything and use the heat shrink with the glue in it should be OK. This is the same thing that happen to the first ECU I had. The board has corrosion on it. I still have it if anyone wants to see it I'll post a picture.
Yah post, that's crazy!
__________________
84 Scrambler Bobbed AMC360 TF727
Klune2.7 d300 lomax 4to1 32sp outputs, 112"wb
14" fox 2.0 3link frt
d60 OX d70 Detroit 4.56 42" IROKs
47 cj2a "GPW" L134 T90 d18
d25 open, d44 open 5.38 31x10.50s
dabshr is offline   Reply With Quote
Old 07-11-2013, 10:02 PM   #59
Mas Tequila
 
Rastus's Avatar
 
Join Date: Nov 2002
Location: San Antonio, Texas
Posts: 18,250
Rastus has disabled reputation
dayum...
__________________
Fame is vapor, popularity an accident, riches take wings. Only one thing endures and that is Character.

Quote:
Originally Posted by RVREDDOG View Post
If you need a ladder to work on your rig you might want to re-think your suspension.
Quote:
Originally Posted by bigevil View Post
thats the look a 14yo boy has the 1st time he sees his 1st set of boobies . its the simple pleasures in life
Quote:
Originally Posted by 4x4Freak View Post
Wood yoo lik two bi a voul? I have won four cell.
Rat Rod City
Rastus is offline   Reply With Quote
Old 07-12-2013, 06:46 AM   #60
Wheels 4 Food
 
Join Date: Nov 2008
Location: Clovis NM
Posts: 3,661
Elcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud of
Quote:
Originally Posted by Rastus View Post
dayum...
Sorry here's a picture of it at the shop not running.

[IMG][/IMG]
__________________
Got to get back to work this playing around isn't paying the bills.

http://i975.photobucket.com/albums/a...Picture769.jpg
Elcaminoman is offline   Reply With Quote
Old 07-12-2013, 06:56 AM   #61
Wheels 4 Food
 
Join Date: Nov 2008
Location: Clovis NM
Posts: 3,661
Elcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud of
Corrosion on first ecu.

[IMG][/IMG]
__________________
Got to get back to work this playing around isn't paying the bills.

http://i975.photobucket.com/albums/a...Picture769.jpg
Elcaminoman is offline   Reply With Quote
Old 07-12-2013, 07:46 AM   #62
Mas Tequila
 
Rastus's Avatar
 
Join Date: Nov 2002
Location: San Antonio, Texas
Posts: 18,250
Rastus has disabled reputation
Quote:
Originally Posted by Elcaminoman View Post
Sorry here's a picture of it at the shop not running.

[IMG][/IMG]
__________________
Fame is vapor, popularity an accident, riches take wings. Only one thing endures and that is Character.

Quote:
Originally Posted by RVREDDOG View Post
If you need a ladder to work on your rig you might want to re-think your suspension.
Quote:
Originally Posted by bigevil View Post
thats the look a 14yo boy has the 1st time he sees his 1st set of boobies . its the simple pleasures in life
Quote:
Originally Posted by 4x4Freak View Post
Wood yoo lik two bi a voul? I have won four cell.
Rat Rod City
Rastus is offline   Reply With Quote
Old 07-16-2013, 06:07 AM   #63
Wheels 4 Food
 
Join Date: Nov 2008
Location: Clovis NM
Posts: 3,661
Elcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud of
Well I got it back yesterday. Unbelievable! I opened the box and they sent it backed with the end covers polished and looks like a new center also polished. That was a great surprise. I was looking at it and noticed they had upgraded the rear leakage as mine was the old rod style. They installed the adjustable up grade. Looks like all new injectors and IAC. And of course a new ECM. I just got done sending them an email thanking them for everything. Never expected that! It's almost to nice to put back on the old rock crawler! Almost.

Now to make some time to install it.
__________________
Got to get back to work this playing around isn't paying the bills.

http://i975.photobucket.com/albums/a...Picture769.jpg
Elcaminoman is offline   Reply With Quote
Old 07-16-2013, 06:46 AM   #64
Flex Master
 
Dirty "OLE" Man's Avatar
 
Join Date: Sep 2004
Location: Waxahachie, TX
Posts: 1,199
Dirty "OLE" Man is a name known to allDirty "OLE" Man is a name known to allDirty "OLE" Man is a name known to allDirty "OLE" Man is a name known to allDirty "OLE" Man is a name known to allDirty "OLE" Man is a name known to all
I sure hope it works out.
__________________
Dirty "OLE" Man
409-651-1818
http://s107.photobucket.com/albums/m...nt=TheFlop.flv
Dirty "OLE" Man is offline   Reply With Quote
Old 07-16-2013, 07:36 AM   #65
Wheels 4 Food
 
Join Date: Nov 2008
Location: Clovis NM
Posts: 3,661
Elcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud of
Quote:
Originally Posted by Dirty "OLE" Man View Post
I sure hope it works out.
Me to,



__________________
Got to get back to work this playing around isn't paying the bills.

http://i975.photobucket.com/albums/a...Picture769.jpg
dabshr likes this.
Elcaminoman is offline   Reply With Quote
Old 07-16-2013, 07:38 AM   #66
Mas Tequila
 
Rastus's Avatar
 
Join Date: Nov 2002
Location: San Antonio, Texas
Posts: 18,250
Rastus has disabled reputation
Quote:
Originally Posted by Elcaminoman View Post
Me to,



that's purty...
__________________
Fame is vapor, popularity an accident, riches take wings. Only one thing endures and that is Character.

Quote:
Originally Posted by RVREDDOG View Post
If you need a ladder to work on your rig you might want to re-think your suspension.
Quote:
Originally Posted by bigevil View Post
thats the look a 14yo boy has the 1st time he sees his 1st set of boobies . its the simple pleasures in life
Quote:
Originally Posted by 4x4Freak View Post
Wood yoo lik two bi a voul? I have won four cell.
Rat Rod City
Rastus is offline   Reply With Quote
Old 07-17-2013, 09:21 AM   #67
Wheels 4 Food
 
Join Date: Nov 2008
Location: Clovis NM
Posts: 3,661
Elcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud of
I'm going to move the ECU time to start cuting wires: Note injector wire position in Tusday the 2nd on the calander.
__________________
Got to get back to work this playing around isn't paying the bills.

http://i975.photobucket.com/albums/a...Picture769.jpg
Elcaminoman is offline   Reply With Quote
Old 07-17-2013, 05:00 PM   #68
Wheels 4 Food
 
Join Date: Nov 2008
Location: Clovis NM
Posts: 3,661
Elcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud ofElcaminoman has much to be proud of
Got all the wires extended, installed it , crank the engine, no start, no tack signal! Then it started raining quick grab the lap top close the hood go inside. About now I'm pissed. So I looking at the weather radar and looks like it's going to rain till 6 or so. It didn't got to go back out about 1/4 past 4 and start checking. The ECU came with a base tune it it and it was set up for a 2 wire dist instead of a single. One click of a button and bam it's running. YEA! I'll have to do some tuning but at least it running.
__________________
Got to get back to work this playing around isn't paying the bills.

http://i975.photobucket.com/albums/a...Picture769.jpg
Elcaminoman is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Complete Audio System DVD/CD, subs, box and amp jptabor24 Non-4x4 related for Sale 5 07-07-2007 12:30 PM
which EFI jfraymond Gas\Diesel Engine & Transmission 7 11-16-2005 10:34 AM
Homemade Cowl Hood/Snorkel System - pics gtxracer Metal Fabrication 8 03-31-2005 02:25 PM


All times are GMT -6. The time now is 03:04 PM.


3.8.7 - Powered by vBulletin
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2017 DragonByte Technologies Ltd.
Copyright 2002-2012 Texas4x4.org
 

SEO by vBSEO 3.6.0