22re issues, Desperate - $100 bounty - Texas 4x4 Forum

Go Back   Texas 4x4 Forum > Technical > Gas\Diesel Engine & Transmission

Photo Gallery Places to Wheel Gallery III Home Forum Tech Section IRCChat FlashChat

Gas\Diesel Engine & Transmission Engine, Transmission, Transfer case

Texas4x4.org is the premier All All Forum on the internet. Registered Users do not see the above ads.

Gas\Diesel Engine & Transmission:

22re issues, Desperate - $100 bounty



Reply
 
Share LinkBack Thread Tools Display Modes
Old 02-15-2009, 09:22 AM   #1
newbie
 
Join Date: Nov 2005
Location: The Woodlands, TX
Posts: 36
NeverSatisfied just gettin started
22re issues, Desperate - $100 bounty

I have a 22re that is driving me nuts in my 85 4runner automatic. I am pulling my hair out. I have an intermittant miss at idle and any constant RPM. It also stumbles before taking off if you crack the throttle from idle to WOT.

What I've checked:
checked for vacuum leaks, verified vacuum routeing. Cant' find anything wrong/leaking
When you jumper TE1 - E1 with key on engine off, I get a single flash every 4.5sec.
With engine running, when I jumper TE1 - E1 It does not bypass ECU timing advance.
Suspected TPS, Tried calibrating.
Tried 2 other known good TPS
Checked for output from TPS at ECU connector

Otherthings done:Fuel Filter, 02, Cap, Rotor, Plugs, Adjust valves, compression 135 across the board, timing set to 5BTC and 12btc, knocked out the cat

Desperate attemps:Swaped ECU, Distributor, Coil, MAF.

I have a broken timing chain guide so I was planning to do a timing chain, guide and OP next, but that shouldn't cause my inability to bypass ECU timing advance. I know the TE1 E1 jumper works because it flashes the check engine light for codes.

I have not checked the Fuel Pressure at the rail or the injectors--I don't have a banjo bolt/fitting to do this. I am throwing my hands up. I will offer $100 if someone is willing to come diagnose/fix this truck. I'm located in Alamo Heights in San Antonio. Thanks for your help.

Shoot me a PM if interested.
__________________
98 xj stock

Last edited by NeverSatisfied; 02-15-2009 at 11:09 AM..
NeverSatisfied is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-15-2009, 10:52 AM   #2
Wheels 4 Food
 
mnmstoy's Avatar
 
Join Date: Apr 2005
Location: SATX
Posts: 6,720
mnmstoy Surfs Venus with Anubismnmstoy Surfs Venus with Anubismnmstoy Surfs Venus with Anubismnmstoy Surfs Venus with Anubismnmstoy Surfs Venus with Anubismnmstoy Surfs Venus with Anubismnmstoy Surfs Venus with Anubismnmstoy Surfs Venus with Anubismnmstoy Surfs Venus with Anubismnmstoy Surfs Venus with Anubismnmstoy Surfs Venus with Anubis
you have a # I have a Buddy that can fix it. Now granted this is to tell you your problem. I'm sure you guys can talk about cost if you want him to fix it.
Give me your number and I will pass it along.
Mike
__________________
Mike
________________________________
1980 Toyota 4.3/465/300 on Propane.
60/14 welded front, detroit rear 5.13 gears.
39.5 IROC on H1's
mnmstoy is offline   Reply With Quote
Old 02-15-2009, 11:06 AM   #3
newbie
 
Join Date: Nov 2005
Location: The Woodlands, TX
Posts: 36
NeverSatisfied just gettin started
To clarify. This is to come diagnose and tell me what's wrong. I'll/we can fix it and I'll cover the parts cost. If it fixes the problem you get $100

Shoot me a PM or send me your number and I'll give you a ring

I have a running 88 and 85 that we can swap parts with to diagnose
__________________
98 xj stock
NeverSatisfied is offline   Reply With Quote
 
Old 02-15-2009, 03:56 PM   #4
Wheels 4 Food
 
mnmstoy's Avatar
 
Join Date: Apr 2005
Location: SATX
Posts: 6,720
mnmstoy Surfs Venus with Anubismnmstoy Surfs Venus with Anubismnmstoy Surfs Venus with Anubismnmstoy Surfs Venus with Anubismnmstoy Surfs Venus with Anubismnmstoy Surfs Venus with Anubismnmstoy Surfs Venus with Anubismnmstoy Surfs Venus with Anubismnmstoy Surfs Venus with Anubismnmstoy Surfs Venus with Anubismnmstoy Surfs Venus with Anubis
Dang....sorry about that Mathew. For some reason I got you mixed up with someone else. Yeeeeeeeaaaaaaaw my buddy says it's not a mechanical issue. It's a electrical one.
Mike
__________________
Mike
________________________________
1980 Toyota 4.3/465/300 on Propane.
60/14 welded front, detroit rear 5.13 gears.
39.5 IROC on H1's
mnmstoy is offline   Reply With Quote
Old 02-15-2009, 04:09 PM   #5
Flex Master
 
Join Date: Jun 2006
Location: Montgomery,TX
Posts: 1,332
RamRock RamRock RamRock RamRock RamRock RamRock RamRock RamRock
I use to have problems with my injectors all the time. Which would cause it to have a bad miss or run on 3 cyl all the time. In a year i when therw 2 sets of them. One of my biggest problems was the plastic wireing harness clip and the o-rings were dry rotted and they would cause the injector to not fire or pull in air.

I ended up buy new wiring harnees clips and o-rings.

I never really missing with any of the emc stuff.
__________________
____________________________
01 RAM 24v Krawlerhauler
97 RAM 4x4 7'in 318/nv4500/231hd
85 Truggy 42"s, Rockwell's, 4.3-th350-Doubler
Pics Link
Texasoffroad.net/galleries/lonestar/RAMROCK
RamRock is offline   Reply With Quote
Old 02-15-2009, 05:34 PM   #6
Flex Master
 
Join Date: Jun 2005
Location: Austin
Posts: 1,203
Glenn is a splendid one to behold - from afarGlenn is a splendid one to behold - from afarGlenn is a splendid one to behold - from afarGlenn is a splendid one to behold - from afarGlenn is a splendid one to behold - from afarGlenn is a splendid one to behold - from afarGlenn is a splendid one to behold - from afar
Check the intake tube from the air cleaner box to the intake manifold. If it's not tight or has cracks/holes in the bellows portion or anything it'll throw off your sensors and cause the condition you're having.
__________________
Another piece of heaven gone to hell.


Blue TJ
Glenn is offline   Reply With Quote
Old 02-15-2009, 05:44 PM   #7
Wheels 4 Food
 
mnmstoy's Avatar
 
Join Date: Apr 2005
Location: SATX
Posts: 6,720
mnmstoy Surfs Venus with Anubismnmstoy Surfs Venus with Anubismnmstoy Surfs Venus with Anubismnmstoy Surfs Venus with Anubismnmstoy Surfs Venus with Anubismnmstoy Surfs Venus with Anubismnmstoy Surfs Venus with Anubismnmstoy Surfs Venus with Anubismnmstoy Surfs Venus with Anubismnmstoy Surfs Venus with Anubismnmstoy Surfs Venus with Anubis
His igniter is also gets extremely hot. My buddy said to replace the coil and ignitor...and if that got hot to replace the computer with a new one.
granted I feel bad for you...I trust in him that he has pointed you in the right direction....with a electrical problem.
Mike
__________________
Mike
________________________________
1980 Toyota 4.3/465/300 on Propane.
60/14 welded front, detroit rear 5.13 gears.
39.5 IROC on H1's
mnmstoy is offline   Reply With Quote
Old 02-15-2009, 07:44 PM   #8
newbie
 
Join Date: Nov 2005
Location: The Woodlands, TX
Posts: 36
NeverSatisfied just gettin started
I'm going to install my ignitor/coil into another known good 85 4runner, I'll report back.
__________________
98 xj stock
NeverSatisfied is offline   Reply With Quote
Old 02-18-2009, 08:18 AM   #9
Wheels 4 Food
 
mnmstoy's Avatar
 
Join Date: Apr 2005
Location: SATX
Posts: 6,720
mnmstoy Surfs Venus with Anubismnmstoy Surfs Venus with Anubismnmstoy Surfs Venus with Anubismnmstoy Surfs Venus with Anubismnmstoy Surfs Venus with Anubismnmstoy Surfs Venus with Anubismnmstoy Surfs Venus with Anubismnmstoy Surfs Venus with Anubismnmstoy Surfs Venus with Anubismnmstoy Surfs Venus with Anubismnmstoy Surfs Venus with Anubis
http://board.marlincrawler.com/index.php?topic=40573.0
http://www.4crawler.com/4x4/CheapTri...#TPSAdjustment
http://board.marlincrawler.com/index...1138#msg511138

here are a few things I think might intrest you in trying to find your problem.
Mike
__________________
Mike
________________________________
1980 Toyota 4.3/465/300 on Propane.
60/14 welded front, detroit rear 5.13 gears.
39.5 IROC on H1's
mnmstoy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 04:35 PM.


3.8.8 - Powered by vBulletin
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright 2002-2012 Texas4x4.org
 

SEO by vBSEO 3.6.0