TBI help - Texas 4x4 Forum

Go Back   Texas 4x4 Forum > Technical > Gas\Diesel Engine & Transmission

Photo Gallery Places to Wheel Gallery III Home Forum Tech Section IRCChat FlashChat

Gas\Diesel Engine & Transmission Engine, Transmission, Transfer case

Texas4x4.org is the premier All All Forum on the internet. Registered Users do not see the above ads.

Gas\Diesel Engine & Transmission:

TBI help



Reply
 
Share LinkBack Thread Tools Display Modes
Old 10-18-2006, 08:21 AM   #1
Flex Master
 
Join Date: Apr 2005
Location: Panhandle
Posts: 1,285
Jeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud of
TBI help

Finally got my truck running and it is acting funny. the truck will idle ok now but if you hit the throttle it almost and sometimes does die. you can ease the throttle open and once you have some rpm's you can crack the rest of the way and no problem. I am thinking MAP or low fuel pressure...what do you guys think?
Jeromy is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-18-2006, 08:58 AM   #2
Cooler'na13floorelevator
 
4x4Freak's Avatar
 
Join Date: Dec 2002
Location: Kermit, TX
Posts: 6,117
4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis
Are you running the right size injectors? Could also be the TPS. You can test both the tps and map sensors, I dont remember how though.
__________________
Zach


Quote:
Originally Posted by RVREDDOG
Thats pretty much how I feel about it....You gone yet?
Reality is an illusion caused by the absence of alcohol.

75 IH Scout II
79 Chevy K10
80 GMC K25
97 Chevy S10
05 Dodge 3500

Collect the whole set.
4x4Freak is offline   Reply With Quote
Old 10-18-2006, 10:09 AM   #3
Flex Master
 
Join Date: Apr 2005
Location: Panhandle
Posts: 1,285
Jeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud of
yea, the whole TB and intake are off a 454....should be more than enought to feed my little 396. I have played and played with the timing and it still doesn't act any better.
Jeromy is offline   Reply With Quote
 
Old 10-18-2006, 11:23 AM   #4
Flex Master
 
Join Date: Apr 2005
Location: Panhandle
Posts: 1,285
Jeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud of
its a TBI system off a 454 that I put on my 396 BBC with harness and custom chip form AFI. I will check the TPS out tonight if I get home before its dark.
Jeromy is offline   Reply With Quote
Old 10-20-2006, 08:08 AM   #5
Flex Master
 
Join Date: Apr 2005
Location: Panhandle
Posts: 1,285
Jeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud of
I replaced the TPS and it still does it. any other ideas....I am thinking maybe low fuel pressure??
Jeromy is offline   Reply With Quote
Old 10-20-2006, 09:39 AM   #6
Wheelin MadMan
 
ontherun's Avatar
 
Join Date: Jul 2004
Location: San Antonio TX
Posts: 921
ontherun is just really happyontherun is just really happyontherun is just really happyontherun is just really happy
fuel pressure will act up at high rpms..run lean condition...check it anyways...alot of time the 02. or the Air idle bypass will make it stumble like that...(not sensing load)..does it throw a code?...And does it do it when the motor reaches temp. and when in gear?L
__________________
L & S
BG² build In progress,.by the new owner
:::::::::::::::::::::::::::::::::::::::::::::::::: :::::::::::::::::::::::::::::::::::::::::::::::
"I have sworn eternal hostility to every form of tyranny over the mind of man." (Jefferson)

Quote:
Originally Posted by Monstercrawler View Post
Lookin good man. I can't freakin wait to beat on that little thing.
ontherun is offline   Reply With Quote
Old 10-20-2006, 09:47 AM   #7
Gonzo Wheeler
 
Donuts1's Avatar
 
Join Date: Mar 2006
Location: Carthage
Posts: 2,632
Donuts1 Surfs Venus with AnubisDonuts1 Surfs Venus with AnubisDonuts1 Surfs Venus with AnubisDonuts1 Surfs Venus with AnubisDonuts1 Surfs Venus with AnubisDonuts1 Surfs Venus with AnubisDonuts1 Surfs Venus with AnubisDonuts1 Surfs Venus with AnubisDonuts1 Surfs Venus with AnubisDonuts1 Surfs Venus with AnubisDonuts1 Surfs Venus with Anubis
Just went throught the same problem. Had a small block with cam heads intake etc. and tbi. Had a custom chip burned for it and it wouldn't run right. Same thing...stumble wouldn't always idle etc. The guy that burned it said the dist. was 180 out....needless to say he's a dumb*ss. To make a long story short we had a chip burned by another guy and everything worked great. Just my 2 cents worth of experience. I personally run carbs and have no problems. Yep, I'm old school!
__________________
Home of the occasional squirrel like energy and sometimes lucky fab porn!
Donuts1 is offline   Reply With Quote
Old 10-20-2006, 10:21 AM   #8
Cooler'na13floorelevator
 
4x4Freak's Avatar
 
Join Date: Dec 2002
Location: Kermit, TX
Posts: 6,117
4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis
Pull the IAC out and check for carbon deposits.
__________________
Zach


Quote:
Originally Posted by RVREDDOG
Thats pretty much how I feel about it....You gone yet?
Reality is an illusion caused by the absence of alcohol.

75 IH Scout II
79 Chevy K10
80 GMC K25
97 Chevy S10
05 Dodge 3500

Collect the whole set.
4x4Freak is offline   Reply With Quote
Old 10-20-2006, 11:42 AM   #9
Flex Master
 
Join Date: Apr 2005
Location: Panhandle
Posts: 1,285
Jeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud of
I will look, at the IAC tonight. I would hope the chip is not the case, I worked with Norm over at AFI for some time on all the specs I wanted.
Jeromy is offline   Reply With Quote
Old 10-20-2006, 04:14 PM   #10
Trail Blazer
 
LEPER's Avatar
 
Join Date: Jul 2005
Location: DALLAS BABY!!!!!
Posts: 678
LEPER SpotterLEPER SpotterLEPER Spotter
Does it happen in neutral or just under load? At what temps?(If it only happens at normal temps, not cold, I would suspect the water temp sensor reading cold and making an over rich condition.) What is the timing set at? Waht size fuel line? What is the fuel pressure at?(Normally starving for fuel will be more apparent under highway driving) Where is the O2 sensor located? How many o2 sensors? Does your setup have a MASS airflow unit on it? What shape is the Dist in?(I had one come apart on me and it produced similar problems before it finally died.)

IIRC you can unlpug the MAP and it will still run. Same with the Mass, it will stumble just off idle.
__________________
www.DallasK5.com

Quote:
Originally Posted by texasfrog View Post
best way I know what mods are necessary is go wheeling and at the end of an obstacle look at all the rigs that made it. now was it driver or parts?
LEPER is offline   Reply With Quote
Old 10-20-2006, 04:36 PM   #11
Flex Master
 
Join Date: Apr 2005
Location: Panhandle
Posts: 1,285
Jeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud ofJeromy has much to be proud of
As far as I can tell it happens at all temps, 3/8 fuel line. Not 100% on timing..have to buy a light this weekend but I have played with it alot. I have not had teh truck more than 30 yards from the trailer. it is Map sensor...I will check the Dist also
Jeromy is offline   Reply With Quote
Old 10-21-2006, 04:49 PM   #12
Wheels 4 Food
 
OldGoat's Avatar
 
Join Date: Oct 2003
Location: Cedar Creek Lake by the Country Club with the other old folks.
Posts: 3,059
OldGoat Surfs Venus with AnubisOldGoat Surfs Venus with AnubisOldGoat Surfs Venus with AnubisOldGoat Surfs Venus with AnubisOldGoat Surfs Venus with AnubisOldGoat Surfs Venus with AnubisOldGoat Surfs Venus with AnubisOldGoat Surfs Venus with AnubisOldGoat Surfs Venus with AnubisOldGoat Surfs Venus with AnubisOldGoat Surfs Venus with Anubis
Possible vacuum leak??? Check the intake gasket to head seal, check to make sure you do not have any vacuum ports open etc...
__________________
Official "WEB WHEELER" and arm chair Quarterback.
OldGoat is offline   Reply With Quote
Old 10-24-2006, 06:25 PM   #13
Rock Stacker
 
Join Date: Apr 2006
Location: austintexas
Posts: 242
zukidave will become famous soon enough
You need to put it on a scaner not a code reader so you can look at data as it's running.You can't fix the computer if you can't talk to it.
__________________
87 sammi waggy dana44,s 538,s locked f/r 5.1t.case 36 ,full cage not much sheet metal left
getting parted out now.
87 sami buggy build (see above)
90 sami 1.3L. efi, spoa, 5to1 t-case, locked rear,
rollin 31" ltb's with the tune's going chillin in the AC
zukidave is offline   Reply With Quote
Old 10-25-2006, 07:45 AM   #14
 
Join Date: Nov 2005
Posts: 35
88K5Blazer just gettin started
I had the same thing happen on my 88 blazer, and it turned out that it was the fuel pump. it had plenty of pressure, but not enough volume. as soon as i changed out the fuel pump, the problem went away. have someone do a pressure test on it. I think you will be suprized.
88K5Blazer is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 06:55 PM.


3.8.8 - Powered by vBulletin
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright 2002-2012 Texas4x4.org
 

SEO by vBSEO 3.6.0