TBI stutter - Texas 4x4 Forum

Go Back   Texas 4x4 Forum > Technical > Gas\Diesel Engine & Transmission

Photo Gallery Places to Wheel Gallery III Home Forum Tech Section IRCChat FlashChat

Gas\Diesel Engine & Transmission Engine, Transmission, Transfer case

Texas4x4.org is the premier All All Forum on the internet. Registered Users do not see the above ads.

Gas\Diesel Engine & Transmission:

TBI stutter



Reply
 
Share LinkBack Thread Tools Display Modes
Old 05-27-2009, 02:54 PM   #1
Flex Master
 
dubbyx's Avatar
 
Join Date: Aug 2005
Location: Lubbock
Posts: 1,515
dubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinaire
TBI stutter

When I first get on the accelerator on this 'burb it hesitates a bit. 350 tbi motor, everything seems to be good on it. Has an idle issue until warm and then the stutter.

Fix/adjustment suggestions?
__________________
Chunky Dunk'n Custom Lures
Visit us at www.chunkydunkn.com
dubbyx is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-27-2009, 04:33 PM   #2
Flex Master
 
Join Date: Jun 2006
Location: Montgomery,TX
Posts: 1,332
RamRock RamRock RamRock RamRock RamRock RamRock RamRock RamRock
Welcome to the tbi sputter off the line.
Ive only been in a hand full of trucks that dont sputter off the line. And they have a ton of work into them. heads,cam and $$$$.

I just power brake mine alittle to get past it..

You running a stock harness or a custom made one. With stuff removed from it.
__________________
____________________________
01 RAM 24v Krawlerhauler
97 RAM 4x4 7'in 318/nv4500/231hd
85 Truggy 42"s, Rockwell's, 4.3-th350-Doubler
Pics Link
Texasoffroad.net/galleries/lonestar/RAMROCK
RamRock is offline   Reply With Quote
Old 05-27-2009, 04:59 PM   #3
Undele' vato
 
Join Date: May 2005
Location: "San Antone"
Posts: 4,970
dott Surfs Venus with Anubisdott Surfs Venus with Anubisdott Surfs Venus with Anubisdott Surfs Venus with Anubisdott Surfs Venus with Anubisdott Surfs Venus with Anubisdott Surfs Venus with Anubisdott Surfs Venus with Anubisdott Surfs Venus with Anubisdott Surfs Venus with Anubisdott Surfs Venus with Anubis
Quote:
Originally Posted by RamRock View Post
Welcome to the tbi sputter off the line.
Ive only been in a hand full of trucks that dont sputter off the line. And they have a ton of work into them. heads,cam and $$$$.
Mine's totally stock with no problems. Wouldn't trade it for any engine.
__________________
Proposed 28th Amendment
"Congress shall make no law that applies to the citizens of the United States that does not apply equally to the Senators and Representatives; and, Congress shall make no law that applies to the Senators and Representatives that does not apply equally to the citizens of the United States".

Git R Dun
My pic folder.
dott is offline   Reply With Quote
 
Old 05-27-2009, 05:24 PM   #4
Rock Monkey
 
Join Date: Mar 2009
Location: Grandview, TX
Posts: 150
hillbilly is a jewel in the roughhillbilly is a jewel in the roughhillbilly is a jewel in the rough
my 95 1/2 ton tbi 350 would sputter when its cold if it hadnt ran for about a week and it kicked the engine light on and an IAC (Idle air control) code on the computer. Id look into that and/or the TPS (throttle position sensor) evan if it dosent give a code they might be the problem. Ive changed them both and havent had a problem since.
hillbilly is offline   Reply With Quote
Old 05-27-2009, 05:41 PM   #5
Flex Master
 
dubbyx's Avatar
 
Join Date: Aug 2005
Location: Lubbock
Posts: 1,515
dubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinaire
All stock. I havn't so much as checked the oil yet. I'm afraid I'll revert to my old ways of tinkering it to death if I do...


The PO did say something about it throwing a trouble light occasionally, but I've yet to see it. I'll pull the codes and see if it says anything. It has a new battery on it, maybe a week old so I'm not going to hold my breath that anything's stored.
__________________
Chunky Dunk'n Custom Lures
Visit us at www.chunkydunkn.com
dubbyx is offline   Reply With Quote
Old 05-27-2009, 05:47 PM   #6
Rock Monkey
 
Join Date: Mar 2009
Location: Grandview, TX
Posts: 150
hillbilly is a jewel in the roughhillbilly is a jewel in the roughhillbilly is a jewel in the rough
I know that mine would store the code and it would act up with out trippin the light so its worth a shot. Check the pig tail on the both of em might be as simple as the clips are broke and the pigtails loose.
hillbilly is offline   Reply With Quote
Old 05-27-2009, 07:47 PM   #7
Flex Master
 
dubbyx's Avatar
 
Join Date: Aug 2005
Location: Lubbock
Posts: 1,515
dubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinaire
Which pigtails are you referring to hillbilly? The TPS and IAC?

You guys will have to forgive me, this is a first time with this system for me so I'm not familiar with it at all.
__________________
Chunky Dunk'n Custom Lures
Visit us at www.chunkydunkn.com
dubbyx is offline   Reply With Quote
Old 05-27-2009, 07:55 PM   #8
Cooler'na13floorelevator
 
4x4Freak's Avatar
 
Join Date: Dec 2002
Location: Kermit, TX
Posts: 6,117
4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis
First place to start is to pull the throttle body off and clean it good. They like to build up carbon. Second, I would check the timing. There is a single wire connector that needs to be disconnected before you do anything to it. Set the timing and reconnect it. It should be up by the firewall somewhere, maybe closer to the distributor. I've never messed with a stock setup, so I cant tell you exactly where it is from the factory.

Also check the spray pattern on the injectors. It should have a nice cone shape. If it's dripping or uneven the injectors need to be cleaned.
__________________
Zach


Quote:
Originally Posted by RVREDDOG
Thats pretty much how I feel about it....You gone yet?
Reality is an illusion caused by the absence of alcohol.

75 IH Scout II
79 Chevy K10
80 GMC K25
97 Chevy S10
05 Dodge 3500

Collect the whole set.
4x4Freak is offline   Reply With Quote
Old 05-27-2009, 08:30 PM   #9
Flex Master
 
dubbyx's Avatar
 
Join Date: Aug 2005
Location: Lubbock
Posts: 1,515
dubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinaire
Awesome Zach. My first thought on it was timing, but there again I wasn't sure how much of it was actually "controlled" and how much of it was pre-set. A good cleaning couldn't hurt it for sure, so I'll start with that tomorrow and check all the connections and such.
__________________
Chunky Dunk'n Custom Lures
Visit us at www.chunkydunkn.com
dubbyx is offline   Reply With Quote
Old 05-28-2009, 05:50 AM   #10
Undele' vato
 
Join Date: May 2005
Location: "San Antone"
Posts: 4,970
dott Surfs Venus with Anubisdott Surfs Venus with Anubisdott Surfs Venus with Anubisdott Surfs Venus with Anubisdott Surfs Venus with Anubisdott Surfs Venus with Anubisdott Surfs Venus with Anubisdott Surfs Venus with Anubisdott Surfs Venus with Anubisdott Surfs Venus with Anubisdott Surfs Venus with Anubis
Quote:
Originally Posted by 4x4Freak View Post
There is a single wire connector that needs to be disconnected before you do anything to it. Set the timing and reconnect it.
BTW, when you do this, the factory timing is "zero" with the plug disconnected. Also, you have to disconnect the wire with the engine off, so that you start it up with the wire disconnected. This is called the "initial" timing. The computer adjusts it as needed from there. If you set the initial timing to 2 degrees BTDC, then it will always be 2 more advanced regardless what the computer does.
__________________
Proposed 28th Amendment
"Congress shall make no law that applies to the citizens of the United States that does not apply equally to the Senators and Representatives; and, Congress shall make no law that applies to the Senators and Representatives that does not apply equally to the citizens of the United States".

Git R Dun
My pic folder.
dott is offline   Reply With Quote
Old 05-28-2009, 09:46 PM   #11
Rock Monkey
 
Join Date: Mar 2009
Location: Grandview, TX
Posts: 150
hillbilly is a jewel in the roughhillbilly is a jewel in the roughhillbilly is a jewel in the rough
Yes I was refering to the IAC and TPS pigtails the clips brake on them sometimes. I have electrical tape holding my IAC because the clip broke and i havent felt like spliceing in a new pigtail
hillbilly is offline   Reply With Quote
Old 05-28-2009, 10:21 PM   #12
Flex Master
 
dubbyx's Avatar
 
Join Date: Aug 2005
Location: Lubbock
Posts: 1,515
dubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinaire
Tinkered a bit on it today. Clips and connections all look good. Pattern on the spray seems good and conical.

With the engine running and the airhorn off, I advanced the throttle by hand just a tad to get the stutter. It showed up and stayed there as long as I held it in position. Either direction I moved it the stutter went away. There was a little wobble in the TPS, so... maybe. I still havn't checked the timing yet. My HF cheapie light is broke--again. I did knock about 3 lbs. of dirt out of the air filter, and replaced it at the next Autozone I passed.
__________________
Chunky Dunk'n Custom Lures
Visit us at www.chunkydunkn.com
dubbyx is offline   Reply With Quote
Old 05-28-2009, 11:38 PM   #13
Wheels 4 Food
 
Join Date: Oct 2004
Location: The Real South Texas
Posts: 7,127
72blazer Surfs Venus with Anubis72blazer Surfs Venus with Anubis72blazer Surfs Venus with Anubis72blazer Surfs Venus with Anubis72blazer Surfs Venus with Anubis72blazer Surfs Venus with Anubis72blazer Surfs Venus with Anubis72blazer Surfs Venus with Anubis72blazer Surfs Venus with Anubis72blazer Surfs Venus with Anubis72blazer Surfs Venus with Anubis
It's funny, ProjectFreedom's TBI sputters like a damn carb too lol
__________________
The Web Wheeler's '72
Motorsport Syndicate:::Edinburg TX
H&H Fabrication:::Amarillo TX
72blazer is offline   Reply With Quote
Old 05-29-2009, 04:52 PM   #14
Cooler'na13floorelevator
 
4x4Freak's Avatar
 
Join Date: Dec 2002
Location: Kermit, TX
Posts: 6,117
4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis
Sounds like the TPS if it's only doing it at a certain throttle position. I'm not sure which terminals to check, but you can check them with an ohm meter. If it's got a bad spot, it should show up.
__________________
Zach


Quote:
Originally Posted by RVREDDOG
Thats pretty much how I feel about it....You gone yet?
Reality is an illusion caused by the absence of alcohol.

75 IH Scout II
79 Chevy K10
80 GMC K25
97 Chevy S10
05 Dodge 3500

Collect the whole set.
4x4Freak is offline   Reply With Quote
Old 05-29-2009, 04:59 PM   #15
Cooler'na13floorelevator
 
4x4Freak's Avatar
 
Join Date: Dec 2002
Location: Kermit, TX
Posts: 6,117
4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis
http://www.autozone.com/autozone/rep...&subtitle=test
__________________
Zach


Quote:
Originally Posted by RVREDDOG
Thats pretty much how I feel about it....You gone yet?
Reality is an illusion caused by the absence of alcohol.

75 IH Scout II
79 Chevy K10
80 GMC K25
97 Chevy S10
05 Dodge 3500

Collect the whole set.
4x4Freak is offline   Reply With Quote
Old 05-29-2009, 05:49 PM   #16
Flex Master
 
dubbyx's Avatar
 
Join Date: Aug 2005
Location: Lubbock
Posts: 1,515
dubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinaire
Wouldn't that just be the wires going into the sensor itself? Would be a lot easier to test there than at the computer--and I think I'll give that a try.

In the past, I would've already bought and replaced the thing. With age and experience I think I'm slowly learning that it's more fun to jack with it for two weeks before spending the money. Of course, it might be that I only got $480 when I sold the last 'burb and spent over $4k on the thing from the time I bought it to the time I sold it. Maybe it's just painful memories holding me back...
__________________
Chunky Dunk'n Custom Lures
Visit us at www.chunkydunkn.com
dubbyx is offline   Reply With Quote
Old 05-29-2009, 09:48 PM   #17
Cooler'na13floorelevator
 
4x4Freak's Avatar
 
Join Date: Dec 2002
Location: Kermit, TX
Posts: 6,117
4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis
You only check it at the computer if there is not enough voltage to the sensor.
__________________
Zach


Quote:
Originally Posted by RVREDDOG
Thats pretty much how I feel about it....You gone yet?
Reality is an illusion caused by the absence of alcohol.

75 IH Scout II
79 Chevy K10
80 GMC K25
97 Chevy S10
05 Dodge 3500

Collect the whole set.
4x4Freak is offline   Reply With Quote
Old 05-29-2009, 09:56 PM   #18
Flex Master
 
dubbyx's Avatar
 
Join Date: Aug 2005
Location: Lubbock
Posts: 1,515
dubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinaire
Ah, gotcha.
__________________
Chunky Dunk'n Custom Lures
Visit us at www.chunkydunkn.com
dubbyx is offline   Reply With Quote
Old 05-30-2009, 08:50 AM   #19
Trail Blazer
 
Join Date: Jun 2006
Location: Spring
Posts: 522
michael0584 will become famous soon enough
Plug up the vacuum line going to the egr valve an see if it still sputters.
__________________
81 Chevy K10 LWB 350 th350 np208
87 fullsize Jimmy (sold)
86 k5 blazer under de-construction
michael0584 is offline   Reply With Quote
Old 05-30-2009, 12:07 PM   #20
Flex Master
 
dubbyx's Avatar
 
Join Date: Aug 2005
Location: Lubbock
Posts: 1,515
dubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinaire
Good call on the EGR valve, that was it.


By the by, if anyone's curious about testing their TPS, Zach's posted method does work quite well. The condensed version: On mine, there are three wires coming out of the top of the TPS. Run ground probe to negative on battery cable, red wire to the TPS. The middle wire is the one you need to check and may need to wiggle the probe around a bit to get good contact. Voltage started at .611v and ran up to a little over 3.5v through the entire curve. The key must be turned to "On" position, test works with the engine stopped(safer) or running(easier to find the dead spot). Simple procedure saved me $27+ tax.
__________________
Chunky Dunk'n Custom Lures
Visit us at www.chunkydunkn.com
dubbyx is offline   Reply With Quote
Old 05-30-2009, 12:27 PM   #21
Wheels 4 Food
 
Join Date: Jul 2006
Location: Harlingen, Texas
Posts: 4,194
projectfreedom has much to be proud ofprojectfreedom has much to be proud ofprojectfreedom has much to be proud ofprojectfreedom has much to be proud ofprojectfreedom has much to be proud ofprojectfreedom has much to be proud ofprojectfreedom has much to be proud ofprojectfreedom has much to be proud ofprojectfreedom has much to be proud ofprojectfreedom has much to be proud of
Quote:
Originally Posted by 72blazer View Post
It's funny, ProjectFreedom's TBI sputters like a damn carb too lol
Mine doesn't sputter, it backfires out the muffler when idling. I am proud to say that when I tell it to go, it goes. I have a problem fouling the plugs on mine.
__________________
Empty
Death is certain, Life is not

He's an arse, but I still wanna wheel with him.
projectfreedom is offline   Reply With Quote
Old 05-30-2009, 01:43 PM   #22
Flex Master
 
dubbyx's Avatar
 
Join Date: Aug 2005
Location: Lubbock
Posts: 1,515
dubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinaire
I lucked out. Vato-zone had two part numbers for the new EGR. Mine was the cheaper
__________________
Chunky Dunk'n Custom Lures
Visit us at www.chunkydunkn.com
dubbyx is offline   Reply With Quote
Old 05-30-2009, 03:03 PM   #23
Flex Master
 
dubbyx's Avatar
 
Join Date: Aug 2005
Location: Lubbock
Posts: 1,515
dubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinaire
Ten yard, $20 penalty for premature celebration...


Figures I'd get the wrong part, no matter what the picture says...
__________________
Chunky Dunk'n Custom Lures
Visit us at www.chunkydunkn.com
dubbyx is offline   Reply With Quote
Old 05-30-2009, 03:48 PM   #24
Cooler'na13floorelevator
 
4x4Freak's Avatar
 
Join Date: Dec 2002
Location: Kermit, TX
Posts: 6,117
4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis
They probably swapped the pictures just so they would sell you the wrong part. I think it's a requirement now that you go to the parts store atleast 3 times so you can fix something.
__________________
Zach


Quote:
Originally Posted by RVREDDOG
Thats pretty much how I feel about it....You gone yet?
Reality is an illusion caused by the absence of alcohol.

75 IH Scout II
79 Chevy K10
80 GMC K25
97 Chevy S10
05 Dodge 3500

Collect the whole set.
4x4Freak is offline   Reply With Quote
Old 05-30-2009, 05:09 PM   #25
Flex Master
 
dubbyx's Avatar
 
Join Date: Aug 2005
Location: Lubbock
Posts: 1,515
dubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinairedubbyx Axle snapper extrordinaire
Generally that seems to be the way it works.

Encountered another case of stupid while I was there. They had to return the part to their system, and refund the money back on my card--rather than just figuring out the difference and charging me that amount. I signed the ticket again, acknowledging the refund and that was that. A little later I asked the guy, "So where's my receipt on that return?" He gave me a blank stare and says, "Sorry, let me get that. I'm not used to getting credit cards in this store--everybody pays cash so I forget."

At least the second one 'sorta' works. The angle of the vacuum line into the valve is a little off and it needs a longer hard line. I finagled it into place and all is well. No stutter.
__________________
Chunky Dunk'n Custom Lures
Visit us at www.chunkydunkn.com
dubbyx is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
350 TBI Problems krawlin1988 Gas\Diesel Engine & Transmission 19 05-19-2009 09:53 PM
350 tbi stuff Txchevy18 For Sale 1 05-15-2009 04:57 PM
Novak 300-700R, NP 208, TBI Wire harness- 3 wire, drag link, CJ console, more.. JJonesee For Sale 0 01-11-2009 06:33 PM
TBI 350........beef it or swap it whiplash776 Gas\Diesel Engine & Transmission 1 03-15-2006 05:47 AM
TBI motor fourwheelerjeff Wanted 2 11-28-2005 12:30 PM


All times are GMT -6. The time now is 03:38 PM.


3.8.8 - Powered by vBulletin
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright 2002-2012 Texas4x4.org
 

SEO by vBSEO 3.6.0