Trouble on a 350 - Texas 4x4 Forum

Go Back   Texas 4x4 Forum > Technical > Gas\Diesel Engine & Transmission

Photo Gallery Places to Wheel Gallery III Home Forum Tech Section IRCChat FlashChat

Gas\Diesel Engine & Transmission Engine, Transmission, Transfer case

Texas4x4.org is the premier All All Forum on the internet. Registered Users do not see the above ads.

Gas\Diesel Engine & Transmission:

Trouble on a 350



Reply
 
Share LinkBack Thread Tools Display Modes
Old 10-25-2006, 12:07 PM   #1
Rock Monkey
 
Join Date: Aug 2006
Location: Edinburg, Texas
Posts: 103
Chief 21 just gettin started
Trouble on a 350

Well just needed some help on a bogging 350. I was wondering if any one has had this problem and could give me ideas. It started at high speed and just got wors. The engine boggs down and feels like it chokes itself dropping my speed. If I rev it on park to around 3-4000 RPMS the engine dies and a gargoling sound appears in the carburator. (Not TBI) I'm thinking that my carb is overflowing thus chocking the engine. I've checked wires, distributor, changed sparkplugs, changed fuel filter, added a gas treatment, cleaned carb with carb cleaner, checked distributor wiring. Does'nt back fire. Idles beutiful. The truck does run ok at slow speed but once it gets to around 45-55 MPH it starts jerking till I'm back to around 30 MPH and I let some of the pedal off. Hope someone has prior expirience on this. Thanx!
__________________
It's easy to destroy - It takes effort to create. A Huevo!
Chief 21 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 10-25-2006, 12:24 PM   #2
Cooler'na13floorelevator
 
4x4Freak's Avatar
 
Join Date: Dec 2002
Location: Kermit, TX
Posts: 6,117
4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis
Sounds like trash in the jets causing it to not let enough gas through.
__________________
Zach


Quote:
Originally Posted by RVREDDOG
Thats pretty much how I feel about it....You gone yet?
Reality is an illusion caused by the absence of alcohol.

75 IH Scout II
79 Chevy K10
80 GMC K25
97 Chevy S10
05 Dodge 3500

Collect the whole set.
4x4Freak is offline   Reply With Quote
Old 10-25-2006, 12:25 PM   #3
Cooler'na13floorelevator
 
4x4Freak's Avatar
 
Join Date: Dec 2002
Location: Kermit, TX
Posts: 6,117
4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis4x4Freak Surfs Venus with Anubis
Could also be a weak fuel pump.
__________________
Zach


Quote:
Originally Posted by RVREDDOG
Thats pretty much how I feel about it....You gone yet?
Reality is an illusion caused by the absence of alcohol.

75 IH Scout II
79 Chevy K10
80 GMC K25
97 Chevy S10
05 Dodge 3500

Collect the whole set.
4x4Freak is offline   Reply With Quote
 
Old 10-25-2006, 12:40 PM   #4
 
Join Date: Nov 2005
Posts: 35
88K5Blazer just gettin started
I would definatly check the fuel pump my blazer did the same thing, and I changed everything, EGR, TPS, plugs, plug wires, injectors etc. and it turns out that as soon as I changed out the pump, it was just fine.
88K5Blazer is offline   Reply With Quote
Old 10-25-2006, 12:48 PM   #5
Gonzo Wheeler
 
Donuts1's Avatar
 
Join Date: Mar 2006
Location: Carthage
Posts: 2,632
Donuts1 Surfs Venus with AnubisDonuts1 Surfs Venus with AnubisDonuts1 Surfs Venus with AnubisDonuts1 Surfs Venus with AnubisDonuts1 Surfs Venus with AnubisDonuts1 Surfs Venus with AnubisDonuts1 Surfs Venus with AnubisDonuts1 Surfs Venus with AnubisDonuts1 Surfs Venus with AnubisDonuts1 Surfs Venus with AnubisDonuts1 Surfs Venus with Anubis
Check the fuel pump, fuel pressure, and also the float level. Sounds more like it's running out of gas rather than getting too much. If the float level is too low, or if there is a peice of trash hung up in the fuel inlet, no matter how much pump and pressure you have you will never be able to keep suffeceint fuel to the engine. If it runs smooth down low, more than likely the jets aren't clogged, but it never hurts to pop the bowls off and check.
__________________
Home of the occasional squirrel like energy and sometimes lucky fab porn!
Donuts1 is offline   Reply With Quote
Old 10-25-2006, 12:48 PM   #6
Rock Monkey
 
Join Date: Aug 2006
Location: Edinburg, Texas
Posts: 103
Chief 21 just gettin started
Thanx for your input guys, will change the fuel pump later on today. We'll see how it goes!
__________________
It's easy to destroy - It takes effort to create. A Huevo!
Chief 21 is offline   Reply With Quote
Old 10-26-2006, 09:50 AM   #7
Trail Blazer
 
LEPER's Avatar
 
Join Date: Jul 2005
Location: DALLAS BABY!!!!!
Posts: 678
LEPER SpotterLEPER SpotterLEPER Spotter
Do you have a cat? A cat or muffler clogging up can produce the same results. You can uncork the exhaust to see if that is the problem.
__________________
www.DallasK5.com

Quote:
Originally Posted by texasfrog View Post
best way I know what mods are necessary is go wheeling and at the end of an obstacle look at all the rigs that made it. now was it driver or parts?
LEPER is offline   Reply With Quote
Old 10-26-2006, 11:52 AM   #8
Trail Blazer
 
fendereff's Avatar
 
Join Date: Sep 2006
Location: Houston, Texas
Posts: 416
fendereff is infamous around these parts
i had the same problem on one of myu carbed engines. wasnt a chevy, but i took the carb off and the jets were pretty clogged. spent a few hours cleaning each piece of the carb and it runs like a champ now. but it does sound like its not getting enough fuel. let us know how it goes
__________________
85 K20 6.2L
fendereff is offline   Reply With Quote
Old 10-30-2006, 11:09 AM   #9
Rock Monkey
 
Join Date: Aug 2006
Location: Edinburg, Texas
Posts: 103
Chief 21 just gettin started
Well cahnged out the fuel pump and has been running awesome since. Don't want to jinx it but it seems to have done the trick. Thanx to all for your help!!!!!!!!!!
__________________
It's easy to destroy - It takes effort to create. A Huevo!
Chief 21 is offline   Reply With Quote
Old 10-30-2006, 11:32 AM   #10
Trail Blazer
 
fendereff's Avatar
 
Join Date: Sep 2006
Location: Houston, Texas
Posts: 416
fendereff is infamous around these parts
awesome...glad its running!
__________________
85 K20 6.2L
fendereff is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
350 turbo to FORD 205 adpt. PYTHON For Sale 10 12-07-2006 01:42 PM
Rebuild of Chevy 350 Redneck Rampage Gas\Diesel Engine & Transmission 7 10-24-2006 08:06 PM
chevy 350 muddyblzr Wanted 5 10-11-2006 07:32 PM
WTB 350 engine. DFW preferred LEPER Wanted 1 10-08-2006 09:47 AM
Having trouble finding a trailer to rent... redwood General chit chat for & about 4x4's. 5 03-02-2006 05:13 PM


All times are GMT -6. The time now is 09:11 AM.


3.8.8 - Powered by vBulletin
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright 2002-2012 Texas4x4.org
 

SEO by vBSEO 3.6.0