Help Please!!!!!! - Texas 4x4 Forum

Go Back   Texas 4x4 Forum > Miscellaneous > General Chit chat.

Photo Gallery Places to Wheel Gallery III Home Forum Tech Section IRCChat FlashChat

General Chit chat. General non-wheeling chit chat between board members.

Texas4x4.org is the premier All All Forum on the internet. Registered Users do not see the above ads.

General Chit chat.:

Help Please!!!!!!



Reply
 
Share LinkBack Thread Tools Display Modes
Old 06-13-2006, 09:22 PM   #1
Trail Blazer
 
LEPER's Avatar
 
Join Date: Jul 2005
Location: DALLAS BABY!!!!!
Posts: 678
LEPER SpotterLEPER SpotterLEPER Spotter
Help Please!!!!!!

My daughters stereo system was stolen tonight at the Allen Cinemark.
It looks like this


4 Alphasonic 10" speakers 1 of them has a white spot on the cone. 1 Alphasonic amplifier, about 28" long. 1 Eclipse amplifier about 20" long. Any info on the parts or who took them is appreciated.
__________________
www.DallasK5.com

Quote:
Originally Posted by texasfrog View Post
best way I know what mods are necessary is go wheeling and at the end of an obstacle look at all the rigs that made it. now was it driver or parts?
LEPER is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -6. The time now is 05:27 PM.


3.8.8 - Powered by vBulletin
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright 2002-2012 Texas4x4.org
 

SEO by vBSEO 3.6.0