Texas 4x4 Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
421 Posts
Discussion Starter · #1 ·
Well i was doin some light 4wheeling after i got the body lift on and it came out of 4wd and wont go back in. Im pretty sure the linkage is fine.

When i get under the car and its in 2wd i can spin the front shaft and i hear a nasty grinding noise coming from the yoke. when i put it in4wd i can not spin the driveshaft but i can grab the lower part of it where it goes to my front axle and spin it. when i do this i hear the same grinding noise. My first guess is the spline on my shaft is worn down and its not catching all the way thus making a nasty sound.

I had a friend watch the shaft and the top half was spinning in foward and revers when i was in 4wd but where it enters the bottom half at the yoke it just vibrates and dosent seem to catch.

This reinforces the hope that it is just my driveshaft.

The reason i would think otherwise is b.c i took it to a transmission place and the guy said my tcase was bad and offerd to take it down that night, saying it would be 80 to drop it and 80 to put it back in, without any repairs done.

What do yall think?

Thanks
 

·
Premium Member
Joined
·
6,117 Posts
main shaft spins inside of yoke + not supposed spin inside of yoke= broken driveshaft
 

·
Registered
Joined
·
2,292 Posts
remember this zach!!! lol

yea we had that happen on his k10 when we was offroading in amarillo.
Basically your shaft is messed up.

did we post about this break??

if i am understanding you right it is the slipyoke you talking about right?
 

·
Registered
Joined
·
421 Posts
Discussion Starter · #4 ·
thanks guys ill get a new shaft then :)
 

·
Registered
Joined
·
3,059 Posts
?

Is it a chain driven case? Is the chain OK or has it possibly broken and is in a big pile in the lower part of the case? Just a thought? Hope it is not the shaft.
 

·
Registered
Joined
·
421 Posts
Discussion Starter · #6 ·
i was hoping it was the shaft. i have 2wheeldrive just fine and i didnt want to drop 300 bux to have the tcase repaired;

i have a np241 im not sure if its chain driven
 

·
Registered
Joined
·
2,292 Posts
hey old goat he is talking about that slipjoint in the middle of the driveshaft so it will expand and clapse as he flex. the splines have worn down to the point that it is not catching. nothing to do with the transfercase or axle.
 

·
Registered
Joined
·
3,059 Posts
oops

lol at myself, went back and re-read it this morning and got a whole different look. Sorry it messed up on you but, even a new one can, just ask Mudgod! Hope it is not too expensive to fix.
 

·
Registered
Joined
·
421 Posts
Discussion Starter · #10 ·
yea the shaft is off and thats the problem, id rather it be that then something in my t-case.

jamminzz
 

·
Registered
Joined
·
230 Posts
Good deal. This reminds me does anyone have a spare front driveshaft for a K5 laying around? I need a spare before I go to Gilmer.
 
1 - 11 of 11 Posts
Top