Texas 4x4 Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
197 Posts
Discussion Starter · #1 ·
im trying to use a tpi system with a 4l60e with a dana 300 adapted to it and im trying to find a tpi system that works with a 4l60e does anybody know the years that gm started putting them together or if they can be combined?
 

·
Registered
Joined
·
832 Posts
If you already have an existing tpi setup and are wanting to mount a 4l60 behind it, the easiest and cost efficient way is a standalone trans control.

If you are wanting to buy the tpi system separately and mount to an existing engine, you need to do your due diligence and research because there a hundred ways to make it work.

All the answers are out there. Just gotta look :)
 

·
Registered
Joined
·
197 Posts
Discussion Starter · #3 ·
i want to buy a tpi separately that mounts to the existing engine im just wondering what vehicles and year should i be looking for? thanks for your reply ive done alot of research just it always seems to be talking about ether the tpi or the trans separately
 

·
Registered
Joined
·
1,460 Posts
Hit up 67_SS396, Ryan has lots of knowledge on this subject.
 

·
Registered
Joined
·
2,375 Posts
You can run a 4L60E behind a TPI. You can use an ECM from a mid 90's (can't remember the year) Express van. You will need to change some of the pins around in the plug, but it's pretty easy. The 4L60 didn't come out until the LT1.
 

·
Registered
Joined
·
2,375 Posts
  • Like
Reactions: Rastus

·
Registered
Joined
·
2,375 Posts
  • Like
Reactions: Rastus
1 - 8 of 8 Posts
Top